升级至WordPress 2.9后插件不兼容的解决方式

升级到Wordpress2.9之后,大部分的插件工作正常,不少插件已经在RC1阶段开发了相对应的兼容性版本以供升级。只要后台升级一下一般都可以解决。这里有几个比较有特色的插件,需要手工处理,比如 Simple Tags 插件

Simple Tags 插件经过测试,在wp2.9上是没有任何问题的,但显示不兼容仅仅是因为自身存在版本检测代码。

修正方式很简单,寻找到如下代码

1
if ( strpos($wp_version,2.7) !== false || strpos($wp_version,2.8) !== false) {

修改为:

1
if ( strpos($wp_version,2.7) !== false || strpos($wp_version,2.8) !== false|| strpos($wp_version,2.9) !== false) {

即可

Related posts

《升级至WordPress 2.9后插件不兼容的解决方式》有2个想法

发表评论